1.03 Oscar update lost all my charts

General Discussion on any topic relating to CPAP and/or Sleep Apnea.
Eddi
Posts: 9
Joined: Sat Feb 06, 2021 4:25 pm

1.03 Oscar update lost all my charts

Post by Eddi » Mon Nov 22, 2021 9:21 am

Hi I updated to 1.3 and despite a backup
, I lost all the info on my card except for the figures down the left side. No charts. I went back to 1.2 but it didn't help.

I have just downloaded Oscar on different Mac and used a card it had not seen on this machine. Same problem tho this time could not find a way back to 1.2

This is weird to me. The info is there on the card starting Dec 28 '19 but not according to OSCAR who only reads from Jan 2021.

Any ideas? I suppose it doesn't really matter s it does get ALL info since I updated in October. It just would have been good to have the graphs for reference

kind regards

User avatar
Jeff8356
Posts: 10
Joined: Mon Jan 04, 2021 11:12 am
Location: North Carolina

Re: 1.03 Oscar update lost all my charts

Post by Jeff8356 » Mon Nov 22, 2021 5:23 pm

A little more info would be helpful...

What CPAP machine are you using (exact model, like Resmed Airsense 10 autoset, etc.)?

The computer you lost your data on, was that also a Mac?
Which version of the OS are you using?
If it was a Mac, is it Intel or the Apple M1 chip?
MacbookAir (Intel) macOS BigSur (11.6.1)
OSCAR 1.3.0
Resmed S10 Autoset w/heated hose
F30 Mask
Pressure 9-14

Eddi
Posts: 9
Joined: Sat Feb 06, 2021 4:25 pm

Re: 1.03 Oscar update lost all my charts

Post by Eddi » Tue Nov 23, 2021 3:02 pm

Hi- AIRSENSE 10 but also used a card from a Phillips Dreamstation which it read previously. The AHI number and the charts were all there back to Dec 2019.

I use the latest Intel just before M1.Big Sur for everyday use such as using it for this and also for Osc ar.

The machine I installed Oscar on last night was a 2019 iMac, I usually just use for photography. Big Sur.

I put in a card it had not read since January when I swapped to the Resmed. I got the same result. On ly the left side info and no graphs with a small sentence at the bottom saying it got no graphs and a sad face.

That to me is weird. I am still using 1.2 as I lost the info as soon as I updated to 1.3 and was still able to scratch and go to 1.2 as I didn't delete the original program download.

I just do not understand how it would do exactly the same on a new machine and new install and with a card that machine had not seen before.

User avatar
BlueDragon
Posts: 484
Joined: Sun May 27, 2018 10:20 am
Location: Sonoran Desert

Re: 1.03 Oscar update lost all my charts

Post by BlueDragon » Tue Nov 23, 2021 3:58 pm

Are you saying that the SD card you imported from had both Dreamstation and Resmed data on the same card? That won't work well. You should always use a new or freshly formatted SD card when using a new or different brand or model line machine.

OSCAR examines your SD card to figure out what kind of machine it is. Since every manufacturer organizes their SD card differently, we have to identify the "footprints" of the CPAP machine which are in the form of file and directory names. It's best to have only one set of "footprints" on the card so OSCAR will identify the machine properly and run the appropriate import code for that machine.

If you have both on the same card, look at the root directory of the card. It should have a folder named P-Series (for Dreamstation) and a file named Identification.tgt (or identification.json in the case of an AirSense 11) for ResMed. Rename the P-Series folder to anything else and import again.
OSCAR 1.3.0 is the latest release. ResMed AirSense 11, F&P SleepStyle, DeVilbiss BLUE, and Chromebooks now supported.
OSCAR Team
ResMed AirCurve 10 VAuto, ResMed AirFit F30 mask
FlashAir SD and FlashPap for data transfer.

Eddi
Posts: 9
Joined: Sat Feb 06, 2021 4:25 pm

Re: 1.03 Oscar update lost all my charts

Post by Eddi » Wed Nov 24, 2021 6:59 am

Hi- sorry for not making it clear.

I one SD for Resmed and a different one for Dreamstation. They have never been used in the wrong machine. They look different. The Phillips one is black and the Resmed is Blue.

No, there is only the info from one make of machine on each card

kind regards

User avatar
BlueDragon
Posts: 484
Joined: Sun May 27, 2018 10:20 am
Location: Sonoran Desert

Re: 1.03 Oscar update lost all my charts

Post by BlueDragon » Wed Nov 24, 2021 8:10 am

Please tell us the exact steps you went through when upgrading to 1.3.0. Did you move any files around? Did you re-import data from existing database?

What should have happened was this:
  1. Install new version of OSCAR
  2. Start OSCAR 1.3.0
  3. OSCAR 1.3.0 would use your existing database and you would see all your data.
OSCAR 1.3.0 is the latest release. ResMed AirSense 11, F&P SleepStyle, DeVilbiss BLUE, and Chromebooks now supported.
OSCAR Team
ResMed AirCurve 10 VAuto, ResMed AirFit F30 mask
FlashAir SD and FlashPap for data transfer.

Eddi
Posts: 9
Joined: Sat Feb 06, 2021 4:25 pm

Re: 1.03 Oscar update lost all my charts

Post by Eddi » Wed Nov 24, 2021 2:39 pm

I did all that.

What is most interesting to me is that when I downloaded Oscar 1.3 onto this iMac which has never had it on before, it rad the card but came up with the same problem. Left side all there and a sad face at the bottom above it saying no graphs to show. I used a card I have not used in almost a year, from the phillips Dreamstation.

I am not going to see what happens on a Windows machine.

User avatar
BlueDragon
Posts: 484
Joined: Sun May 27, 2018 10:20 am
Location: Sonoran Desert

Re: 1.03 Oscar update lost all my charts

Post by BlueDragon » Wed Nov 24, 2021 5:07 pm

I suggest you make a zip file of your SD card and upload it to my Dropbox folder. Please include your forum name in the zip file name so we know who the file is from. I will see what is on it.
OSCAR 1.3.0 is the latest release. ResMed AirSense 11, F&P SleepStyle, DeVilbiss BLUE, and Chromebooks now supported.
OSCAR Team
ResMed AirCurve 10 VAuto, ResMed AirFit F30 mask
FlashAir SD and FlashPap for data transfer.

User avatar
Jeff8356
Posts: 10
Joined: Mon Jan 04, 2021 11:12 am
Location: North Carolina

Re: 1.03 Oscar update lost all my charts

Post by Jeff8356 » Fri Nov 26, 2021 3:21 am

Eddi wrote:
Wed Nov 24, 2021 2:39 pm

I am not going to see what happens on a Windows machine.
It's beginning to sound like something happened to the data on the SD card so it's not likely that Windows will be of any help. Please zip a copy of the SD card and upload it to BlueDragon so he can try to make sense of it.

Just curious..... When you remove the SD card from your Mac(s) do you just yank it out? Or do you eject it first?
MacbookAir (Intel) macOS BigSur (11.6.1)
OSCAR 1.3.0
Resmed S10 Autoset w/heated hose
F30 Mask
Pressure 9-14

Eddi
Posts: 9
Joined: Sat Feb 06, 2021 4:25 pm

Re: 1.03 Oscar update lost all my charts

Post by Eddi » Fri Nov 26, 2021 6:49 am

Hi -sorry for slow responses.

I uploaded all to Windows. Yes, it appears the Resmed card is corrupted because it had all the charts on the Win machine from Phillips. I was hopeful then that it would read the Resmed files, iot went thru it's process but still everything before the time I updated to 1.3 has no graphs.
Yes I eject first but I often get the 'you removed...without ejecting' message even though the card is still there. But this has been going on since I have used the card so would wonder why it would make a difference now.

I am now going to try and make a zip from it.

Thanks all.

Eddi
Posts: 9
Joined: Sat Feb 06, 2021 4:25 pm

Re: 1.03 Oscar update lost all my charts

Post by Eddi » Fri Nov 26, 2021 6:59 am

I have posted the .zip of SD card to the DropBox. Thanks.

User avatar
Jeff8356
Posts: 10
Joined: Mon Jan 04, 2021 11:12 am
Location: North Carolina

Re: 1.03 Oscar update lost all my charts

Post by Jeff8356 » Fri Nov 26, 2021 10:37 am

Eddi wrote:
Fri Nov 26, 2021 6:49 am

Yes I eject first but I often get the 'you removed...without ejecting' message even though the card is still there.

Thanks all.
If you are ejecting the card and still getting that error message it usually means that something is still accessing the card and trying to read/write to it. Could be Finder/Spotlight or OSCAR. Looking in the left pane of Finder it should show you if the SD card ejected or not. If you keep hitting the eject button and it is not ejecting then something else is still using it. Don't remove the card until you figure out what is still using it. Close any open apps, and try to eject again.
MacbookAir (Intel) macOS BigSur (11.6.1)
OSCAR 1.3.0
Resmed S10 Autoset w/heated hose
F30 Mask
Pressure 9-14

User avatar
BlueDragon
Posts: 484
Joined: Sun May 27, 2018 10:20 am
Location: Sonoran Desert

Re: 1.03 Oscar update lost all my charts

Post by BlueDragon » Fri Nov 26, 2021 11:59 am

The data on the SD card is fine and imported properly into my copy of OSCAR. The data and graphs look fine.

Try the following steps to see if this changes the result:
  1. Reboot your computer
  2. Start OSCAR
  3. Create a new profile
  4. Insert your SD card in the SD reader on your computer
  5. Import the SD card into OSCAR (make sure you are importing from the SD drive and not some other location)
  6. After importing, eject the card using the Windows Safely Remove function. Let us know if it doesn't think the card can be removed yet.
  7. Look at the Daily page
If all is not well, please take a screenshot of the Daily page and post it here.
OSCAR 1.3.0 is the latest release. ResMed AirSense 11, F&P SleepStyle, DeVilbiss BLUE, and Chromebooks now supported.
OSCAR Team
ResMed AirCurve 10 VAuto, ResMed AirFit F30 mask
FlashAir SD and FlashPap for data transfer.

Eddi
Posts: 9
Joined: Sat Feb 06, 2021 4:25 pm

Re: 1.03 Oscar update lost all my charts

Post by Eddi » Wed Dec 01, 2021 12:06 pm

Thank you. I don't know why I didn't think of creating a new profile myself.

Created new profile. Waited for it to do it's thing. Imported into new profile. However, it only has graphs back to August 4th, the last day it shows graphs for. Now that is further than before, which went only as far back as the day in October I updated to 1.3. I am NOT using 1.3 now but 1.2. I went back to 1.2 very soon after the update and noticing the graph loss.

I am going to try again with a new profile.

Eddi
Posts: 9
Joined: Sat Feb 06, 2021 4:25 pm

Re: 1.03 Oscar update lost all my charts

Post by Eddi » Wed Dec 01, 2021 12:16 pm

Rebooted etc, new profile, still not graphs before August 4th 2021. I can live with it.

Thank you kindly.