Quantcast

Bookmark and Share
General Discussion on any topic relating to CPAP and/or Sleep Apnea.
cgooden
 
Posts: 1
Joined: Thu Sep 15, 2011 8:59 pm
Gender: None specified

Service Required

Postby cgooden on Thu Sep 15, 2011 9:10 pm

I have had a Respironic RemStar Pro Auto CPAP Machine for about a year now, lately the machine is sounding an alarm and shutting off during the night. When this occurs the display will say "Service Required". I was wondering if anyone might know what could be causing the alarm, and how to fix it. The only way to shut off the alarm off is to pull the power cord,

Also there are times that I am lying in bed but not sleeping and the LED on my CPAP machine will come on and the machine enter the ramp mode spontaneously. Any indeas of what would be causing these issues? Downloading the data from the card, does not indicate any alarms.

MidnightOwl
 
Posts: 367
Joined: Thu Feb 22, 2007 11:49 pm
Gender: None specified

Re: Service Required

Postby MidnightOwl on Thu Sep 15, 2011 9:23 pm

Sorry. I don't know about the code but I'm sure someone else will know more.

Do you own this machine or are you renting it? If by some small chance you are still renting it report the problem immediately and get it replaced now before you do own it. Call them tonight! If you own it - did you buy it new? Mine came with a warranty. The warranty was from the manufacturer but had to be pursued thru the equipment dealer (DME).

User avatar
archangle
 
Posts: 7626
Joined: Sun Mar 27, 2011 11:55 am
Gender: Male

Re: Service Required

Postby archangle on Fri Sep 16, 2011 9:52 am

cgooden wrote:I have had a Respironic RemStar Pro Auto CPAP Machine for about a year now, lately the machine is sounding an alarm and shutting off during the night. When this occurs the display will say "Service Required". I was wondering if anyone might know what could be causing the alarm, and how to fix it. The only way to shut off the alarm off is to pull the power cord,

Also there are times that I am lying in bed but not sleeping and the LED on my CPAP machine will come on and the machine enter the ramp mode spontaneously. Any indeas of what would be causing these issues? Downloading the data from the card, does not indicate any alarms.


Welcome to the board.

First, let's figure out which machine you have. There are 3 versions of "REMstar" machine. The newest ones say "Philips Respironics." One level back says "REMstar xxx M series" near the power buttons. The older versions just say "REMstar". Which do you have?

Does the air hose come out the back, the top, the side, or the front?

"PRO" and "Auto" are two different models.

Does it say anything other than "Service Required?" Numbers, etc.?

_________________
Machine: S9 AutoSet™ CPAP Machine
Mask: Swift™ FX Nasal Pillow CPAP Mask with Headgear
Humidifier: S9™ Series H5i™ Heated Humidifier with Climate Control
Additional Comments: Also SleepyHead, PRS1 Auto, Respironics Auto M series, Legacy Auto, and Legacy Plus
Please enter your equipment in your profile so we can help you.
Click here for information on the most common alternative to CPAP.
If it's midnight and a DME tells you it's dark outside, go and check for yourself.

Useful Links.

alex a
 
Posts: 20
Joined: Mon Nov 01, 2010 7:31 pm
Gender: Male

Re: Service Required

Postby alex a on Mon Jan 02, 2012 4:18 pm

I have had the same issue for the last couple of nights. I have a Remstar DS550S Auto. Any ideas of what I could do before mailing it in for service? I own this unit.

_________________
Machine Mask Humidifier 

User avatar
LSAT
 
Posts: 4352
Joined: Sun Nov 16, 2008 10:11 am
Location: SE Wisconsin
Gender: Male

Re: Service Required

Postby LSAT on Mon Jan 02, 2012 4:31 pm

I would always start by pulling the plug for a few minutes and letting the CPAP re-boot...just like a computer. It may do nothing, but it won't hurt to try.


Regenesis Buckwheat Hull Pillow
Backup machine is F&P Sleepstyle 200

User avatar
GumbyCT
 
Posts: 5789
Joined: Fri Sep 14, 2007 6:22 pm
Location: CT
Gender: None specified

Re: Service Required

Postby GumbyCT on Mon Jan 02, 2012 4:35 pm

alex a wrote:I have had the same issue for the last couple of nights. I have a Remstar DS550S Auto. Any ideas of what I could do before mailing it in for service? I own this unit.

You can't do a thing, well 'cept to contact a DME cuz the manufacturer won't talk or deal with you.

Be sure to ask for a loaner while it is out for repair.

How old is it? Did it get water spilled inside or just fall?
BeganCPAP31Jan2007;AHI<0.5
I have no doubt, how I sleep affects every waking moment.
I am making progress-NOW I remember that I can't remember
;)
If this isn’t rocket science why are there so many spaceshots?
Be your own healthcare advocate!

alex a
 
Posts: 20
Joined: Mon Nov 01, 2010 7:31 pm
Gender: Male

Re: Service Required

Postby alex a on Tue Mar 06, 2012 8:11 pm

well the machine worked well after I replaced the sd card and then 1 month later it finally died. CPAP.com was very nice to deal with and I shipped it to them and they sent it to respironics. after 2 weeks I was sent a new machine!! :D

_________________
Machine Mask Humidifier 


Return to CPAP and Sleep Apnea (CLICK HERE TO READ POSTS)

Who is online

Users browsing this forum: BlackSpinner, englandsf, JCraig, RicaLynn, Stevoreno_55 and 46 guests